Orders are being show as duplicates
Incident Report for Security Lock Distributors
Resolved
This incident has been resolved.
Posted Apr 20, 2018 - 11:13 EDT
Identified
We are working to resolve an issue where orders from April 19 and April 20 are being shown multiple times in order history.
Posted Apr 20, 2018 - 09:49 EDT