SECLOCK.com experiencing outages

Incident Report for Seclock

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 14:39 EST

Identified

Products are not loading, and 502 errors are being shown.
Posted Feb 04, 2026 - 13:11 EST
This incident affected: Web (seclock.com).