Search on seclock.com sometimes fails
Incident Report for Security Lock Distributors
Resolved
Search is back to normal
Posted Jul 01, 2019 - 10:32 EDT
Investigating
We are aware of an issue where searching sometimes fails to bring back results. We are actively working on resolving the issue.
Posted Jul 01, 2019 - 09:57 EDT
This incident affected: Web (seclock.com).