Pricing and availability are down
Incident Report for Security Lock Distributors
Resolved
This incident has been resolved.
Posted Jul 26, 2018 - 15:20 EDT
Update
We are continuing to investigate this issue.
Posted Jul 26, 2018 - 14:39 EDT
Investigating
We are investigating an outage in pricing and availability on the site.
Posted Jul 26, 2018 - 14:38 EDT
This incident affected: APIs (Developer API) and Web (seclock.com).